ESP8266 not working


+ Reply to Thread
Results 1 to 6 of 6

Thread: ESP8266 not working79 days old

  1. #1
    Prolific Poster normnet's Avatar
    Join Date
    Jul 2004
    Posts
    2,428
    Thumbs Up
    Received: 81
    Given: 48
    Total Downloaded
    1.40 GB

    0 Not allowed!

    Default ESP8266 not working

    No luck running the following. What AT command might I have missed? When I enter my received IP address in a web browser the page times out.

    Code:
          HSerOut ["AT+CWMODE=3",13,10] '3 = join other WiFi AP + serves as an WiFi AP)
          HSerIn [Wait("OK")]
          SerOut cSEROUT_PIN,cBAUD, ["AT+CWMODE=3 OK",13]
    
          HSerOut ["AT+CWLAP",13,10] 'search for WiFi network available
          HSerIn [Wait("OK")]
          SerOut cSEROUT_PIN,cBAUD, ["AT+CWLAP OK",13]
    
          HSerOut ["AT+CWJAP=",34,"xxxxxxx",34,",",34,"xxxxxxx",34,13,10] '34 = " 'JOIN NETWORK
          HSerIn [Wait("OK")]
          SerOut cSEROUT_PIN,cBAUD, ["AT+CWJAP OK",13]
    
          HSerOut ["AT+CIFSR",13,10] 'GET IP address
          HSerIn [Wait("OK")]
          SerOut cSEROUT_PIN,cBAUD, ["AT+CIFSR OK",13]
    
          HSerOut ["AT+CIPMUX=1",13,10] 'turn on multiple connection to this module
          HSerIn [Wait("OK")]
          SerOut cSEROUT_PIN,cBAUD, ["AT+CIPMUX=1 OK",13]
    
          HSerOut ["AT+CIPSERVER=1,80",13,10] 'use standard port 80
          HSerIn [Wait("OK")]
          SerOut cSEROUT_PIN,cBAUD, ["AT+CIPSERVER=1,80 OK",13]
    
          HSerOut ["AT+CIPSEND=0,11",13,10] 'SEND DATA LENGTH  '***** FAILS HERE "link is not valid" "ERROR" *****
          HSerIn [Wait("OK")]
          SerOut cSEROUT_PIN,cBAUD, ["AT+CIPSEND=0,11 OK",13]
    
          HSerOut ["HELLO WORLD"] 'SEND DATA
          HSerIn [Wait("OK")]
          SerOut cSEROUT_PIN,cBAUD, ["HELLO WORLD OK",13]
    
          HSerOut ["AT+CIPCLOSE=0",13,10] 'CLOSE
          HSerIn [Wait("OK")]
          SerOut cSEROUT_PIN,cBAUD, ["AT+CIPCLOSE=0 OK",13]
    
    '      SerOut RESULTS:
    '      AT+CWMODE=3 OK
    '      AT+CWLAP OK
    '      AT+CWJAP OK
    '      AT+CIFSR OK
    '      AT+CIPMUX=1 OK
    '      AT+CIPSERVER=1,80 OK
    Norm

  2. Attention

    This valuable resource relies upon the very small amount of revenue generated by displaying online advertisements to our visitors.

    The advertisements we display are relevant to this web site and your browsing history

    Please consider supporting us by disabling your ad blocker.


    Note: Some users have reported issues related to ad-blockers rendering parts of this wesite unusable,
    where possible we will rectify the issues to enable you to use this resource with adblocking enabled.

    If you can, please report issues in the forum area WebSite / Forum Issues


    Thank you for your attention.

  3. #2
    Prolific Poster normnet's Avatar
    Join Date
    Jul 2004
    Posts
    2,428
    Thumbs Up
    Received: 81
    Given: 48
    Total Downloaded
    1.40 GB

    0 Not allowed!

    Default Re: ESP8266 not working

    I can ping the IP address however the IP address when entered into a browser times out.
    Also the AT+CIPSEND=0,11 command always is an ERROR.
    From a version which includes display of responses is the following:
    Code:
    AT+CWMODE=3
    
    
    
    
    OK
    
    AT+CWLAP
    
    
    +CWLAP:(4,"ROGNESSNETGEAR",-76,"e0:91:f5:6d:19:ca",1,26,0)
    
    +CWLAP:(3,"fallensteind",-88,"00:1a:2b:b0:51:75",1,31,0)
    
    +CWLAP:(3,"NETGEAR93-5G_2GEXT",-85,"10:da:43:8b:04:a0",1,28,0)
    
    +CWLAP:(3,"Vault-Tec",-74,"a0:04:60:dc:6a:b0",1,48,0)
    
    +CWLAP:(3,"CCI61DC",-40,"22:02:71:7c:e4:41",10,51,0)
    
    +CWLAP:(3,"belkin.935",-83,"22:02:71:88:0b:d6",10,25,0)
    
    +CWLAP:(4,"Schemmel",-82,"60:38:e0:89:bf:40",4,21,0)
    
    +CWLAP:(3,"NETGEAR37",-81,"a0:40:a0:96:48:22",4,30,0)
    
    +CWLAP:(3,"DIRECT-24-HP OfficeJet Pro 6970",-89,"84:a9:3e:f8:93:25",6,55,0)
    
    +CWLAP:(3,"turnip_EXT",-84,"a0:04:60:29:6f:92",8,31,0)
    
    +CWLAP:(3,"turnip",-83,"dc:ef:09:d0:14:b6",8,23,0)
    
    +CWLAP:(3,"Barnett",-84,"10:0d:7f:90:9e:d4",9,36,0)
    
    +CWLAP:(3,"MyCharterWiFif2-2G",-72,"dc:ef:09:9f:b9:f2",11,60,0)
    
    +CWLAP:(3,"MySpectrumWiFi04-2G",-77,"40:4c:77:d7:c9:05",11,38,0)
    
    +CWLAP:(0,"CiscoD0749",-91,"68:7f:74:94:1f:32",11,35,0)
    
    
    
    OK
    
    T+CWJAP="xxxxxxx","xxxxxxx"
    
    
    WIFI DISCONNECT
    
    WIFI CONNECTED
    
    WIFI GOT IP
    
    
    
    OK
    
    AT+CIFSR
    
    
    +CIFSR:APIP,"192.168.x.xx"
    
    +CIFSR:APMAC,"4a:3f:da:69:e6:76"
    
    +CIFSR:STAIP,"192.168.x.xx"
    
    +CIFSR:STAMAC,"48:3f:da:69:e6:76"
    
    
    
    OK
    
    AT+CIPMUX=1
    
    
    
    
    OK
    
    T+CIPSERVER=1,80
    
    
    no change
    
    
    
    OK
    
     ***** IN FOLLOWING NO "OK" RESPONSE FOUND *****
    AT+CIPSEND=0,11
    
    
    link is not valid
    
    
    
    ERROR
    
     ***** IN FOLLOWING NO "OK" RESPONSE FOUND *****
    HELLO WORLD
    
     ***** IN FOLLOWING NO "OK" RESPONSE FOUND *****
    AT+CIPCLOSE=0
    
    
    UNLINK
    
    
    
    ERROR

  4. Attention

    This valuable resource relies upon the very small amount of revenue generated by displaying online advertisements to our visitors.

    The advertisements we display are relevant to this web site and your browsing history

    Please consider supporting us by disabling your ad blocker.


    Note: Some users have reported issues related to ad-blockers rendering parts of this wesite unusable,
    where possible we will rectify the issues to enable you to use this resource with adblocking enabled.

    If you can, please report issues in the forum area WebSite / Forum Issues


    Thank you for your attention.

  5. #3
    Member keytapper's Avatar
    Join Date
    Jun 2019
    Posts
    245
    Thumbs Up
    Received: 11
    Given: 6
    Total Downloaded
    463.40 MB

    0 Not allowed!

    Default Re: ESP8266 not working

    I'd like to share some trouble to use the ESP. For several reasons I faced impossible to get a clear reply. Many times I received just garbled characters, which means some missed UART synchronization or the core dumping the failures.

  6. Attention

    This valuable resource relies upon the very small amount of revenue generated by displaying online advertisements to our visitors.

    The advertisements we display are relevant to this web site and your browsing history

    Please consider supporting us by disabling your ad blocker.


    Note: Some users have reported issues related to ad-blockers rendering parts of this wesite unusable,
    where possible we will rectify the issues to enable you to use this resource with adblocking enabled.

    If you can, please report issues in the forum area WebSite / Forum Issues


    Thank you for your attention.

  7. #4
    Prolific Poster normnet's Avatar
    Join Date
    Jul 2004
    Posts
    2,428
    Thumbs Up
    Received: 81
    Given: 48
    Total Downloaded
    1.40 GB

    0 Not allowed!

    Default Re: ESP8266 not working

    Quote Originally Posted by keytapper View Post
    I'd like to share some trouble to use the ESP. For several reasons I faced impossible to get a clear reply. Many times I received just garbled characters, which means some missed UART synchronization or the core dumping the failures.
    The ESP8266 default baud of 115,200 is the max speed tween a PIC and a PC for example so a crystal may be required and perhaps a faster Hz 3.3 volt PIC as well if that helps? The ESP8266 baud can be reduced once communicating.

    Norm

  8. Attention

    This valuable resource relies upon the very small amount of revenue generated by displaying online advertisements to our visitors.

    The advertisements we display are relevant to this web site and your browsing history

    Please consider supporting us by disabling your ad blocker.


    Note: Some users have reported issues related to ad-blockers rendering parts of this wesite unusable,
    where possible we will rectify the issues to enable you to use this resource with adblocking enabled.

    If you can, please report issues in the forum area WebSite / Forum Issues


    Thank you for your attention.

  9. #5
    Member keytapper's Avatar
    Join Date
    Jun 2019
    Posts
    245
    Thumbs Up
    Received: 11
    Given: 6
    Total Downloaded
    463.40 MB

    0 Not allowed!

    Default Re: ESP8266 not working

    Quote Originally Posted by normnet View Post
    The ESP8266 baud can be reduced once communicating.
    You're right, probably that may be done with an USB-UART adapter.

  10. Attention

    This valuable resource relies upon the very small amount of revenue generated by displaying online advertisements to our visitors.

    The advertisements we display are relevant to this web site and your browsing history

    Please consider supporting us by disabling your ad blocker.


    Note: Some users have reported issues related to ad-blockers rendering parts of this wesite unusable,
    where possible we will rectify the issues to enable you to use this resource with adblocking enabled.

    If you can, please report issues in the forum area WebSite / Forum Issues


    Thank you for your attention.

  11. #6
    Prolific Poster normnet's Avatar
    Join Date
    Jul 2004
    Posts
    2,428
    Thumbs Up
    Received: 81
    Given: 48
    Total Downloaded
    1.40 GB

    0 Not allowed!

    Default Re: ESP8266 not working

    Quote Originally Posted by keytapper View Post
    You're right, probably that may be done with an USB-UART adapter.
    I perhaps misspoke. I was trying to show 115200 baud is quite fast so a good setup may be required.

    Norm

  12. Attention

    This valuable resource relies upon the very small amount of revenue generated by displaying online advertisements to our visitors.

    The advertisements we display are relevant to this web site and your browsing history

    Please consider supporting us by disabling your ad blocker.


    Note: Some users have reported issues related to ad-blockers rendering parts of this wesite unusable,
    where possible we will rectify the issues to enable you to use this resource with adblocking enabled.

    If you can, please report issues in the forum area WebSite / Forum Issues


    Thank you for your attention.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Similar Threads

  1. Replies: 5
    Last Post: 29th October 2018, 19:43
  2. Esp01 esp8266 + pic
    By Pic in forum WiFi
    Replies: 7
    Last Post: 3rd June 2016, 18:37
  3. ESP8266 wifi module
    By RayEllam in forum WiFi
    Replies: 29
    Last Post: 1st October 2015, 00:24
  4. ESP8266 wifi module
    By RayEllam in forum The Lounge
    Replies: 27
    Last Post: 21st September 2015, 17:16
  5. Project working at proteuse .... but not working at real
    By MedTronic in forum Projects discussion
    Replies: 5
    Last Post: 19th July 2013, 13:26

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts