Error[113] ... Symbol not previously defined (__HRSIN1__)


Today 01:28
Forum: Proton Plus Compiler v3
Starter: BenBarber
Views: 4587
Replies: 43
Go to last post By: david
Yesterday 23:42
Forum: Proton 24
Starter: hadv215
Views: 0
Replies: 8
Go to last post By: shantanu@india
Yesterday 14:45
Forum: The Lounge
Starter: Tim
Views: 0
Replies: 17
Yesterday 14:03
Forum: USB
Starter: towlerg
Views: 0
Replies: 5
Yesterday 11:10
Forum: Proton Studio
Starter: johngb
Views: 0
Replies: 3
Yesterday 07:48
Forum: Proton 24
Starter: craig
Views: 0
Replies: 2
Yesterday 07:10
Forum: The Lounge
Starter: shantanu@india
Views: 0
Replies: 25
+ Reply to Thread
Results 1 to 4 of 4
  1. #1
    Junior Member wirecut's Avatar
    Join Date
    Nov 2018
    Posts
    5
    Thumbs Up
    Received: 0
    Given: 0
    Total Downloaded
    0

    0 Not allowed!

    Default Error[113] ... Symbol not previously defined (__HRSIN1__)

    Hi to all.

    After some time of absence to this great forum (I was cancelled, and I do not have understand why), I'm back again.

    I install te new version of the compiler 3.7.0.3 from the previous release that I was using 3.6.0.2.

    Compiling and old program that is working for years on a 18F4550 and I obtain the errors message as follow:

    Message[308] D:\ my directory \A.S 133 : Warning level superseded by command line value. (2)
    Error[113] D:\ my directory \A.S 1843 : Symbol not previously defined (__HRSIN1__)
    Error[113] D:\ my directory \A.S 5841 : Symbol not previously defined (__HRSIN1__)

    I have search but do not found some helps.

    Also I have forget some things about PDS due to the long absence due to following other projects.

    Any suggestion is appreciate.

    Leo

  2. Attention

    This valuable resource relies upon the very small amount of revenue generated by displaying online advertisements to our visitors.

    The advertisements we display are relevant to this web site and your browsing history

    Please consider supporting us by disabling your ad blocker.


    Note: Some users have reported issues related to ad-blockers rendering parts of this wesite unusable,
    where possible we will rectify the issues to enable you to use this resource with adblocking enabled.

    If you can, please report issues in the forum area WebSite / Forum Issues


    Thank you for your attention.

  3. #2
    Administrator John Drew's Avatar
    Join Date
    Feb 2002
    Posts
    2,633
    Thumbs Up
    Received: 119
    Given: 31
    Total Downloaded
    3.15 GB

    0 Not allowed!

    Default Re: Error[113] ... Symbol not previously defined (__HRSIN1__)

    Hi Leo,
    I forget exactly but some years back it was necessary to put Declare in front of some declarations that previously didn't need the word. That may be the problem.
    John

  4. Attention

    This valuable resource relies upon the very small amount of revenue generated by displaying online advertisements to our visitors.

    The advertisements we display are relevant to this web site and your browsing history

    Please consider supporting us by disabling your ad blocker.


    Note: Some users have reported issues related to ad-blockers rendering parts of this wesite unusable,
    where possible we will rectify the issues to enable you to use this resource with adblocking enabled.

    If you can, please report issues in the forum area WebSite / Forum Issues


    Thank you for your attention.

  5. #3
    Junior Member wirecut's Avatar
    Join Date
    Nov 2018
    Posts
    5
    Thumbs Up
    Received: 0
    Given: 0
    Total Downloaded
    0

    0 Not allowed!

    Default Re: Error[113] ... Symbol not previously defined (__HRSIN1__)

    Hi John,

    is a long time that I stay outside from the forum and I'm happy to meet you again.
    I has been moved to China in Shenzhen.
    Many thanks for the suggestion.

    From my point of view everything seems ok on my code. I remember about the problem of Declare, but I do not see anyhing that is irregular now.
    To solve fastly the problem I have disinstalled the relase 3.7.0.3 and re-installed the release 3.6.0.2 and now everything is OK.

    I know that is a workaround and the best is to have the latest version of PDS.

    The problem came with the Les serial port buffered, but all to me seem correct! The release 3.6.0.2 is not too old.

    Can I send to you in PM the code and you take a look and suggest to me where I need to add the Declare?

    Leo
    Last edited by wirecut; 10th March 2019 at 10:47. Reason: typing errors

  6. Attention

    This valuable resource relies upon the very small amount of revenue generated by displaying online advertisements to our visitors.

    The advertisements we display are relevant to this web site and your browsing history

    Please consider supporting us by disabling your ad blocker.


    Note: Some users have reported issues related to ad-blockers rendering parts of this wesite unusable,
    where possible we will rectify the issues to enable you to use this resource with adblocking enabled.

    If you can, please report issues in the forum area WebSite / Forum Issues


    Thank you for your attention.

  7. #4
    Administrator John Drew's Avatar
    Join Date
    Feb 2002
    Posts
    2,633
    Thumbs Up
    Received: 119
    Given: 31
    Total Downloaded
    3.15 GB

    0 Not allowed!

    Default Re: Error[113] ... Symbol not previously defined (__HRSIN1__)

    Hi Leo,
    I'm just an ordinary user but of course I will look at the code for you.
    I will send you a PM with my email address.
    John

  8. Attention

    This valuable resource relies upon the very small amount of revenue generated by displaying online advertisements to our visitors.

    The advertisements we display are relevant to this web site and your browsing history

    Please consider supporting us by disabling your ad blocker.


    Note: Some users have reported issues related to ad-blockers rendering parts of this wesite unusable,
    where possible we will rectify the issues to enable you to use this resource with adblocking enabled.

    If you can, please report issues in the forum area WebSite / Forum Issues


    Thank you for your attention.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Similar Threads

  1. Symbol not previously defined i_PPS_FN_RX2
    By gtv_pic in forum Proton Plus Compiler v3
    Replies: 20
    Last Post: 18th March 2019, 15:57
  2. Symbol not previously defined - Another assemble error
    By mjturner in forum Proton Plus Compiler v3
    Replies: 3
    Last Post: 11th January 2019, 22:53
  3. Replies: 5
    Last Post: 4th February 2018, 22:40
  4. Symbol not previously defined (PP3) error
    By David Snook in forum Proton Plus Compiler v3
    Replies: 2
    Last Post: 24th February 2017, 16:58

Members who have read this thread since 23rd March 2019, 01:15 : 0

Actions :  (Set Date)  (Clear Date)

You do not have permission to view the list of names.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts