Today 21:10
Forum: Proton Plus Compiler v3
Starter: Dave-S
Views: 0
Replies: 13
Today 21:05
Forum: Absolute Beginners Section
Starter: KevinPBaker
Views: 0
Replies: 2
Today 17:23
Forum: Website / Forum Issues
Starter: Lester
Views: 0
Replies: 7
Go to last post By: KevinPBaker
Today 16:25
Forum: Test Postings
Starter: KevinPBaker
Views: 0
Replies: 0
Today 15:18
Forum: Proton Plus Compiler v3
Starter: Fred Philpott
Views: 0
Replies: 1
Yesterday 23:13
Forum: Proton Plus Compiler v3
Starter: IstvanK
Views: 0
Replies: 7
+ Reply to Thread
Results 1 to 9 of 9

Thread: Proton IDE not saving files correctly33 days old

  1. #1
    Member Dave-S's Avatar
    Join Date
    Sep 2004
    Posts
    253
    Thumbs Up
    Received: 5
    Given: 0
    Total Downloaded
    268.81 MB

    1 Not allowed!

    Default Proton IDE not saving files correctly

    I have a problem that the IDE is not saving files correctly.
    Create a folder for Project, and start to create a .bas file which I save to that folder. I copy .inc files to that folder. As I continue creating .bas file, some times it saves it to that folder and other times it saves it to the PDS root folder. I first became aware there was a problem when trying to compile the file it stated "there was no configuration fuses for the device, these are in the .inc file but it was looking in the PDS root folder.
    Then things went really wrong, I opened the .inc file to check the Config fuses and then clicked to compile with this file still selected and it saved this .inc file over the top of my .bas file, losing the contents, so now I have to start again.

  2. #2
    Prolific Poster towlerg's Avatar
    Join Date
    Mar 2012
    Posts
    1,323
    Thumbs Up
    Received: 51
    Given: 122
    Total Downloaded
    2.37 GB

    0 Not allowed!

    Default Re: Proton IDE not saving files correctly

    What OS are you running?
    George

  3. #3
    Prolific Poster RGV250's Avatar
    Join Date
    Aug 2005
    Posts
    2,276
    Thumbs Up
    Received: 23
    Given: 4
    Total Downloaded
    322.53 MB

    0 Not allowed!

    Default Re: Proton IDE not saving files correctly

    Hi Dave,
    I may have misunderstood this so apologies if it is not the problem you have but I think mine does the same so I have just accepted it as just one of those things. It all depends on what you do beforehand.
    If I create a file and do a "save as" to the correct directory and then subsequently "save" it always saves it to the correct directory, if I close PDS and then open it up again, edit the file and "save" it saves it in the PDS root directory.

    Regards,
    Bob

  4. #4
    Member Dave-S's Avatar
    Join Date
    Sep 2004
    Posts
    253
    Thumbs Up
    Received: 5
    Given: 0
    Total Downloaded
    268.81 MB

    0 Not allowed!

    Default Re: Proton IDE not saving files correctly

    Quote Originally Posted by towlerg View Post
    What OS are you running?
    Windows 7 64 bit

  5. #5
    Member Dave-S's Avatar
    Join Date
    Sep 2004
    Posts
    253
    Thumbs Up
    Received: 5
    Given: 0
    Total Downloaded
    268.81 MB

    0 Not allowed!

    Default Re: Proton IDE not saving files correctly

    Quote Originally Posted by RGV250 View Post
    Hi Dave,
    I may have misunderstood this so apologies if it is not the problem you have but I think mine does the same so I have just accepted it as just one of those things. It all depends on what you do beforehand.
    If I create a file and do a "save as" to the correct directory and then subsequently "save" it always saves it to the correct directory, if I close PDS and then open it up again, edit the file and "save" it saves it in the PDS root directory.

    Regards,
    Bob
    With a file loaded and you click on it to edit it, it shows the correct folder at the top but saves to the PDS folder.
    When you open it up, if it loads a file from a certain directory after editing it should save it to that directory.
    If you click on compile on a .inc file it should not overwrite that file over the .bas file.

  6. #6
    Prolific Poster towlerg's Avatar
    Join Date
    Mar 2012
    Posts
    1,323
    Thumbs Up
    Received: 51
    Given: 122
    Total Downloaded
    2.37 GB

    0 Not allowed!

    Default Re: Proton IDE not saving files correctly

    I have seen the same thing RGV250 describes and also can live with it.

    In your case, do you have the "Default startup source folder" option turned on?
    George

  7. #7
    Member Dave-S's Avatar
    Join Date
    Sep 2004
    Posts
    253
    Thumbs Up
    Received: 5
    Given: 0
    Total Downloaded
    268.81 MB

    0 Not allowed!

    Default Re: Proton IDE not saving files correctly

    Quote Originally Posted by towlerg View Post
    I have seen the same thing RGV250 describes and also can live with it.

    In your case, do you have the "Default startup source folder" option turned on?
    Yes. It would be nice if it opened the last file/folder or had a recent file selection as other editors do.

  8. #8
    Prolific Poster towlerg's Avatar
    Join Date
    Mar 2012
    Posts
    1,323
    Thumbs Up
    Received: 51
    Given: 122
    Total Downloaded
    2.37 GB

    0 Not allowed!

    Default Re: Proton IDE not saving files correctly

    I'm not sure I understand your last post.

    On my machine if I close the IDE with a files/files loaded, they will be reloaded when I restart the IDE. The reopen option in the files menu always show the last n files disregarding launch/close.

    I assume the "default startup source folder" is peeps who stick everything in one directory.
    George

  9. #9
    Prolific Poster See_Mos's Avatar
    Join Date
    Feb 2004
    Posts
    1,177
    Thumbs Up
    Received: 2
    Given: 0
    Total Downloaded
    435.78 MB

    0 Not allowed!

    Default Re: Proton IDE not saving files correctly

    I used to get something like this when there are more than three .BAS files open in the editor or sometimes after a long session of editing and compiling. Now I just close any files that I am not currently working on.

    I am also using W7
    My RAM is failing

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Similar Threads

  1. Proton IDE Compiler wont run/Crashes when IDE is run on my Windows 7
    By XMAXY123 in forum Proton Plus Compiler v3
    Replies: 11
    Last Post: 5th February 2012, 10:06
  2. Replies: 8
    Last Post: 15th November 2011, 19:54
  3. Old Proton Board & Proton IDE
    By bravo in forum Proton Development Board
    Replies: 2
    Last Post: 21st June 2011, 21:04
  4. Proton IDE search in all files?
    By DmitriK in forum Wish List / Product Feedback
    Replies: 2
    Last Post: 9th November 2008, 08:01
  5. Proton IDE
    By Bentron in forum Proton Plus Compiler v3
    Replies: 0
    Last Post: 20th February 2006, 05:07

Members who have read this thread : 43

Actions :  (Set Date)

You do not have permission to view the list of names.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts