issues with config-start, config end fuse settings on 18F


+ Reply to Thread
Results 1 to 7 of 7
  1. #1
    katesfb
    Guest katesfb's Avatar

    0 Not allowed!

    Default issues with config-start, config end fuse settings on 18F

    Hi.
    I have just started using config-start, config-end for setting the fuses:
    Code:
    'setup 18f chip--------------------------------------------------------------
    Config_Start
        ;OSC = HSPLL    'xtrnl Oscillator high speed unsing internal scaler to get 40MHTZ
        OSC = HS    'xtrnl Oscillator high speed
        FSCM = OFF  'Fail-Safe Clock Monitor disabled
        IESO = OFF  'Internal External Switch Over mode disabled
        PWRT = On   'power on reset Enabled
        BOR = On    'brown out reset Enabled
        BORV = 27   'reset voltage 2.7V
        WDT = OFF   'Disabled
        MCLRE = OFF  'Enabled
        STVR = OFF  'disabled
        LVP = OFF   'Disabled
        Debug = OFF     'Disabled
    Config_End
    However i have noticed that if i change BORV to 42 (4.2V) is doesnt work. Has anybody else found this?

    Chip = 18F1320, IDE = 2.0.0.7, compiler = 3.5.0.6

    Any help is much appreciated.

    Cheers.

Attention

This valuable resource relies upon the very small amount of revenue generated by displaying online advertisements to our visitors.

The advertisements we display are relevant to this web site and your browsing history

Please consider supporting us by disabling your ad blocker.


Note: Some users have reported issues related to ad-blockers rendering parts of this wesite unusable,
where possible we will rectify the issues to enable you to use this resource with adblocking enabled.

If you can, please report issues in the forum area WebSite / Forum Issues


Thank you for your attention.

  • #2
    pverburg
    Guest pverburg's Avatar

    0 Not allowed!

    Default Re: issues with config-start, config end fuse settings on 18F

    You really should register and upgrade first I don't think anybody is using the version you are working with any more many fixes and enhancements have been done to the compiler.

  • Attention

    This valuable resource relies upon the very small amount of revenue generated by displaying online advertisements to our visitors.

    The advertisements we display are relevant to this web site and your browsing history

    Please consider supporting us by disabling your ad blocker.


    Note: Some users have reported issues related to ad-blockers rendering parts of this wesite unusable,
    where possible we will rectify the issues to enable you to use this resource with adblocking enabled.

    If you can, please report issues in the forum area WebSite / Forum Issues


    Thank you for your attention.

  • #3
    katesfb
    Guest katesfb's Avatar

    0 Not allowed!

    Default Re: issues with config-start, config end fuse settings on 18F

    Hi Paul,
    Thanks for the reply. I thought this compiler was the most up to date version as it was what i upgraded to only a few days ago (compiler i am using now is ver 3.5.0.6 old one was 3.2.X.X).

    I have also tried to become a liscenced user but every time i try it doesn't seem to work even though i follow the correct procedure:
    "access the "Forum Actions" at the top left of the page in the line beginning "New posts">Then choose General Settings> Complete the form with invoice number and click on Validate me>The Crownhill staff will update you to a licensed user after checking your purchase details"

    So have given up for now.

    Any help is much appreciated.

    Cheers.

  • Attention

    This valuable resource relies upon the very small amount of revenue generated by displaying online advertisements to our visitors.

    The advertisements we display are relevant to this web site and your browsing history

    Please consider supporting us by disabling your ad blocker.


    Note: Some users have reported issues related to ad-blockers rendering parts of this wesite unusable,
    where possible we will rectify the issues to enable you to use this resource with adblocking enabled.

    If you can, please report issues in the forum area WebSite / Forum Issues


    Thank you for your attention.

  • #4
    pverburg
    Guest pverburg's Avatar

    0 Not allowed!

    Default Re: issues with config-start, config end fuse settings on 18F

    you wont be able to get the latest compiler until you validate its only available for registered licensed users.
    Where did you purchased the compiler from if you have a copy of the invoice Crownhill will activate you, I can't recall selling a copy to you ? did you get it in the UK or USA

  • Attention

    This valuable resource relies upon the very small amount of revenue generated by displaying online advertisements to our visitors.

    The advertisements we display are relevant to this web site and your browsing history

    Please consider supporting us by disabling your ad blocker.


    Note: Some users have reported issues related to ad-blockers rendering parts of this wesite unusable,
    where possible we will rectify the issues to enable you to use this resource with adblocking enabled.

    If you can, please report issues in the forum area WebSite / Forum Issues


    Thank you for your attention.

  • #5
    Prolific Poster hadv215's Avatar
    Join Date
    Sep 2009
    Posts
    1,135
    Thumbs Up
    Received: 66
    Given: 26
    Total Downloaded
    3.31 GB

    0 Not allowed!

    Default Re: issues with config-start, config end fuse settings on 18F

    I tested it, it works with 3.5.2.1.
    Try to locate the P18F1320.PPI file under ProtonIde\PDS\Includeds\PPI.
    Now use an editor to locate BORV.
    Should look something like this:
    ; Brown-out Voltage:
    BORV=45 ; 4.5V
    BORV=42 ; 4.2V
    BORV=27 ; 2.7V
    If 42 is missing you can just try to add that line.

    Now look for ;Configuration Byte 2L Options
    BORV_27_2 EQU 0XFB ; BOR Voltage - 2.7v
    BORV_42_2 EQU 0XF7 ; 4.2v
    BORV_45_2 EQU 0XF3 ; 4.5v
    add the line you need

    after saving, try again.
    Last edited by hadv215; 26th August 2011 at 21:15.

  • Attention

    This valuable resource relies upon the very small amount of revenue generated by displaying online advertisements to our visitors.

    The advertisements we display are relevant to this web site and your browsing history

    Please consider supporting us by disabling your ad blocker.


    Note: Some users have reported issues related to ad-blockers rendering parts of this wesite unusable,
    where possible we will rectify the issues to enable you to use this resource with adblocking enabled.

    If you can, please report issues in the forum area WebSite / Forum Issues


    Thank you for your attention.

  • #6
    katesfb
    Guest katesfb's Avatar

    0 Not allowed!

    Default Re: issues with config-start, config end fuse settings on 18F

    Quote Originally Posted by pverburg View Post
    you wont be able to get the latest compiler until you validate its only available for registered licensed users.
    Where did you purchased the compiler from if you have a copy of the invoice Crownhill will activate you, I can't recall selling a copy to you ? did you get it in the UK or USA
    Hi Paul,
    Was originally purchased from the UK in about 2005. The executable on the disk is PDEV310.exe. The problem has been that we lost the original invoice although when i last tried to get licensed Crownhill were able to find us in the system without the invoice so i thought every thing was OK but then the forum site moved or something and had to re-register and i think everything got stuffed up again.

    Cheers.

  • Attention

    This valuable resource relies upon the very small amount of revenue generated by displaying online advertisements to our visitors.

    The advertisements we display are relevant to this web site and your browsing history

    Please consider supporting us by disabling your ad blocker.


    Note: Some users have reported issues related to ad-blockers rendering parts of this wesite unusable,
    where possible we will rectify the issues to enable you to use this resource with adblocking enabled.

    If you can, please report issues in the forum area WebSite / Forum Issues


    Thank you for your attention.

  • #7
    katesfb
    Guest katesfb's Avatar

    0 Not allowed!

    Default Re: issues with config-start, config end fuse settings on 18F

    Quote Originally Posted by hadv215 View Post
    I tested it, it works with 3.5.2.1.
    Try to locate the P18F1320.PPI file under ProtonIde\PDS\Includeds\PPI.
    Now use an editor to locate BORV.
    Should look something like this:
    ; Brown-out Voltage:
    BORV=45 ; 4.5V
    BORV=42 ; 4.2V
    BORV=27 ; 2.7V
    If 42 is missing you can just try to add that line.

    Now look for ;Configuration Byte 2L Options
    BORV_27_2 EQU 0XFB ; BOR Voltage - 2.7v
    BORV_42_2 EQU 0XF7 ; 4.2v
    BORV_45_2 EQU 0XF3 ; 4.5v
    add the line you need

    after saving, try again.
    Hi, and thanks for the reply - year i checked the file and all the relevant lines were in there so thats not causing the problem. I have since also discovered that the chip doesnt seem to work if the HSPLL option is chosen.

    Any Ideas?

    Cheers.

  • Attention

    This valuable resource relies upon the very small amount of revenue generated by displaying online advertisements to our visitors.

    The advertisements we display are relevant to this web site and your browsing history

    Please consider supporting us by disabling your ad blocker.


    Note: Some users have reported issues related to ad-blockers rendering parts of this wesite unusable,
    where possible we will rectify the issues to enable you to use this resource with adblocking enabled.

    If you can, please report issues in the forum area WebSite / Forum Issues


    Thank you for your attention.

    Thread Information

    Users Browsing this Thread

    There are currently 1 users browsing this thread. (0 members and 1 guests)

       

    Similar Threads

    1. Need help with fuse config :(
      By flexassem in forum Projects discussion
      Replies: 6
      Last Post: 10th May 2016, 16:26
    2. Which folder do I have to look to get config settings
      By zerone in forum Proton Plus Compiler v3
      Replies: 1
      Last Post: 27th January 2010, 16:27
    3. 18f config settings for internal oscillator
      By richardy in forum Proton Plus Compiler v3
      Replies: 5
      Last Post: 18th June 2008, 01:56
    4. [SOLVED !] 18F config fuses
      By richardy in forum Proton Plus Compiler v3
      Replies: 11
      Last Post: 18th January 2008, 14:42
    5. Config Settings PIC18F6722
      By AnthonyHarris in forum Proton Plus Compiler v3
      Replies: 4
      Last Post: 22nd August 2006, 21:21

    Members who have read this thread : 12

    Actions :  (Set Date)

    You do not have permission to view the list of names.

    Tags for this Thread

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts