Search Results - Proton BASIC community web site


Search:

Type: Posts; User: rcurl

Page 1 of 3 1 2 3

Search: Search took 0.03 seconds.

  1. Replies
    9
    Views
    10

    Re: spi interface to HD44780 LCD display

    Hi Charlie-
    It's not from Les, but will this help? http://www.protonbasic.co.uk/showthread.php/62478-%93Print%94-command-for-SPI-Alfa-numeric-LCD

    -Rick
  2. Replies
    37
    Views
    38

    I dont belive it ! Re: Back in time looking good !

    807's look like big tubes until you see one of these:
    3635
    I was at a shortwave radio station over the past weekend helping fix one of their four 500,000 watt transmitters. The final tube is the...
  3. Replies
    19
    Views
    20

    Re: Diffuser IR Leds (how)

    Hi Tim-
    does the sensor only work in the IR range? I wonder if it may have sensitivity in the visible range. If it does, then you have a lot more options, like CCFL tubes, or the LED arrays used...
  4. Replies
    14
    Views
    15

    Re: Remote programming with Pickkit2

    ....and along the same lines, if you have the power jumpered internally like that, don't plug it into a circuit that requires 3.3 volts while the USB is plugged in.

    -Rick
  5. Replies
    11
    Views
    12

    Re: Ethernet to RS232 converter

    I have used some https://www.lantronix.com/products/xport/
    You can map them to each other, so it acts like a serial cable that works over Ethernet, or you can use their com port...
  6. Replies
    14
    Views
    15

    Re: Remote programming with Pickkit2

    I use the "programmer to go" mode all the time and it works great. I also added a jumper wire inside the Pickit 2's between Vcc on the ICSP connector back to +5 on the USB connector so the Pickit...
  7. Thread: PICKitPlus Forum

    by rcurl
    Replies
    7
    Views
    8

    Sticky: Re: PICKitPlus Forum

    Pickit Plus does work great with PDS, including from within the IDE.
    I set up two programmer entries; one for 5 volts and one for 3.3 volts. I used the string:

    -w -e -a5 -pPIC$target-device$...
  8. Replies
    41
    Views
    42

    Re: Advertisement on the forum

    Sounds good to me as long as I can use PayPal to pay for it.
    -Rick
  9. Thread: Library Loader

    by rcurl
    Replies
    2
    Views
    3

    Re: Library Loader

    Hi John-
    Good to hear from you again!
    I installed the Library Loader, and the good news is that it does work. I'm not terribly impressed, though.
    Samacsys does not have libraries for Diptrace. ...
  10. Replies
    31
    Views
    32

    Web site advertising

    FYI- At the top of each page I'm seeing this:

    --- This is a test - only visible to admins ---
    --- advertisement may go here ---

    ....but I'm not an Admin, so something my be set incorrectly.
    ...
  11. Replies
    14
    Views
    15

    Re: PIC18F1330 PLL problem

    Tumbleweed nailed it. Changing from "Internal Oscillator Block" to "Primary Oscillator" got it running at 32Mhz. Microchip seems to have gone out of their way to make this confusing.
    Thanks to...
  12. Replies
    14
    Views
    15

    Re: PIC18F1330 PLL problem

    Thanks for all the responses. Sorry to be slow responding. One of our goats broke a horn off last night (ouch!!) and we've been focused on getting her taken care of.
    I'll get back on this project...
  13. Replies
    14
    Views
    15

    Re: PIC18F1330 PLL problem

    Thanks, George. Testing the IOFS bit didn't help, and I'm not sure how to check FOSC3:FOSC0. The oscillator type is being set by Fuse Configurator.

    -Rick
  14. Replies
    14
    Views
    15

    Re: PIC18F1330 PLL problem

    Thanks, Charlie. Unfortunately that didn't do it.

    I haven't needed to write any code in several months, so it's likely I'm making a bonehead mistake somewhere. I've used the PLL many times on...
  15. Replies
    14
    Views
    15

    PIC18F1330 PLL problem

    I'm just starting out on a new project that uses a PIC18F1330. I haven't used this specific chip before, so I began by trying to blink an LED just to make sure I've got things working right. My LED...
  16. Replies
    10
    Views
    11

    Re: User Articles not accessible

    I'm sure that was tough to find. Thanks for fixing it. Lester!

    -Rick
  17. Replies
    10
    Views
    11

    Re: User Articles not accessible

    Sorry to be slow responding.

    All OK now. Thanks, Lester!

    -Rick
  18. Replies
    10
    Views
    11

    User Articles not accessible

    I just noticed that If I click on any of the "user articles" at the top right side of the forum top level menu page, such as:...
  19. Replies
    103
    Views
    104

    Re: Malware on this website?

    Thanks guys! ESPECIALLY LESTER!
    Sorry that ended up being so complicated and frustrating. All your hard work is really appreciated.

    -Rick
  20. Replies
    103
    Views
    104

    Re: Malware on this website?

    Strange- I'm not seeing any of these problems. I usually use Opera, but I just tried Chrome, Firefox, and IE, with no problems on any of them. Could it be that problem has been resolved?

    -Rick
  21. Re: Is it possible to add another sample like Ser_buffer.bas?

    I like what you've done with the robot!! Very nice.

    I'm sure you'll get some responses about the serial buffer soon.

    -Rick
  22. Replies
    16
    Views
    17

    Re: Driving SK9822 or APA102 RGB LED's

    Hi guys-
    I made a couple changes and it is working better. I added the declare "Shift_DelayUS 100" and changed the Shout command to MSBFirst_L so the clock will idle low.
    It seems to be stable...
  23. Replies
    16
    Views
    17

    Re: Driving SK9822 or APA102 RGB LED's

    Well- it seems to be working ....at least occasionally. I'm using this code:

    SPIloop:
    SHOut PORTC.2, PORTC.0, MsbFirst, [$00,$00,$00,$00] 'start frame
    ...
  24. Replies
    16
    Views
    17

    Re: Driving SK9822 or APA102 RGB LED's

    Thanks, Dave! Much appreciated. Looks like it uses a software SPI driver instead of the MSSP, but at this point I just want to see some LED's light up!

    I'll convert it to PDS when I get home...
  25. Replies
    16
    Views
    17

    Re: Driving SK9822 or APA102 RGB LED's

    Thanks for the info!
    I can't seem to get anything out of the SPI Master.

    I've got the MSSP set up like this:


    All_Digital = true
    Declare Xtal = 16

    '* Set I/O pin direction *
  26. Replies
    14
    Views
    1,661

    Re: 16f1503 AND PWM modules

    Yep- that fixed it. I thought I was on the latest version, but it turns out that on my laptop I was on 3.6.0.3. I did the update, went back to my original code, and everything is working perfectly....
  27. Replies
    16
    Views
    17

    Driving SK9822 or APA102 RGB LED's

    I've been trying to figure out how to drive SK9822 or APA102 RGB LED's using the MSSP module in a PIC16F1503 but I'm getting nowhere. Part of the problem is that I haven't used MSSP SPI mode with a...
  28. Replies
    14
    Views
    1,661

    Re: 16f1503 AND PWM modules

    Yep- Already checked it. In this case the Erratas didn't apply. In the past, I've been burned by their Erratas on more than one occasion. In one case, I implemented their workaround and when they...
  29. Replies
    14
    Views
    1,661

    Re: 16f1503 AND PWM modules

    Thanks, Les. You're the best!

    Giving you a LEGITIMATE thumbs up on your post.

    -Rick
  30. Replies
    4
    Views
    5

    Re: A question for Americans

    Thanks, George. I'll give it a look.

    -Rick
  31. Replies
    14
    Views
    1,661

    Re: 16f1503 AND PWM modules

    I was writing code for a 16F1503 and I could not get PWM2 to work. PWM's 1,3, and 4 were fine. The PPI file for the PIC looks fine.

    I downloaded Les' PWM library replacement routine and it fixed...
  32. Replies
    4
    Views
    5

    Re: A question for Americans

    Hi George-
    Are you going to make me watch the movie or are you going to tell us?

    I checked IMDB and didn't see the movie listed. What's the whole name? Is it any good?

    -Rick
  33. Replies
    26
    Views
    27

    Re: Dim xxx as code problem on P24

    You mean like cleaning the registry? :)
    -Rick
  34. Replies
    32
    Views
    33

    Re: New PICkit 4 available

    Hi John- I think we're in the same boat. My PSA results just came back as .05, so all is good.

    As for the Pickit 4- It's under a pile of stuff in a drawer somewhere. I'm not going to bother with...
  35. Replies
    14
    Views
    15

    Re: Ferrite transformer question

    eBay is a good source for Litz wire. I'm using some that has 53 strands of #33 wire Two 4-turn windings driven in push-pull by a resonant zero-voltage switch. It runs about 30Khz. I've got a 4 mil...
Results 1 to 35 of 100
Page 1 of 3 1 2 3