• PicŪ Basic


  • Example Code

    Published on 17th January 2017 16:58

    A Forum User presented this question...and Les offered a solution
    I'm working with the Microchip MCP1630 LED driver board using a PIC12F683 controller, and they offer the firmware in assembler.

    How can use this assembler in Proton, so I can modify it? If I set the device type in Proton and enclose their code between Asm- and Endasm- I get quite a few different assembler errors. Am I doing something basically wrong?

    John

    ...

    Don't post here. Please choose one of the sub-categories under Example Code that best fit your article. If one of the current ...

    Here you will find snippets of working code that will help save you time. Please help add to our collection of examples by contributing code that you have written.

  • Recent Activity

    shantanu@india-969

    PicKit3 Programmer

    Thread Starter: Dave-S

    Trying to setup a PicKit3 Programmer. Has gone through the install programmer and the Dos screen flashes up but does not stay there, and it does not...

    shantanu@india Today, 12:01 Go to last post
    charliecoultas-16125

    complie issue

    Thread Starter: chuckieboy

    Hi All It's been a long time since I've played with PDS. Back in 2013 I wrote a program all working correctly, I've recently was required to make an...

    charliecoultas Today, 11:11 Go to last post
    Frizie-140

    Issue with MID$

    Thread Starter: Frizie

    Hi people! I have a small issue with the MID$ command. If I put a semi-colon in the source-string then I get the compiler error: Unbalanced...

    Frizie Today, 10:19 Go to last post
    Dave-S-350

    UMC Loader

    Thread Starter: Dave-S

    Trying to use the MicroCode loader, but when I select either Loader or Loader Options from the "View" menu it just opens my Melabs Programmer. How...

    Dave-S Today, 08:20 Go to last post
    towlerg-21522

    16F627 - How do I enable pull-ups on PORTB?

    Thread Starter: davroski

    Hi, Data sheet says OPTION register bit 7 (RBPU) should be set to 0 but compiler 3.5.9.9 doesn't seem to recognise OPTION.7 = 0 or RBPU = 0 Thanks...

    towlerg Today, 01:02 Go to last post